Справочник по с – Справочник программиста — общие сведения о переменных и массивах данных на itProger

Справочник по C# | Microsoft Docs

  • Время чтения: 5 мин

В этой статье

Этот раздел содержит подробные справочные сведения о ключевых словах, операторах, специальных символах, директивах препроцессора, параметрах компилятора и ошибках и предупреждениях компилятора в среде C#.This section provides reference material about C# keywords, operators, special characters, preprocessor directives, compiler options, and compiler errors and warnings.

Содержание разделаIn this section

Ключевые слова в C#C# Keywords
Ссылки на сведения о ключевых словах и синтаксисе языка C#.Provides links to information about C# keywords and syntax.

Операторы в C#C# Operators
Ссылки на сведения об операторах и синтаксисе языка C#.Provides links to information about C# operators and syntax.

Специальные символы в C#C# Special Characters

Предоставляет ссылки на сведения о специальных контекстные символов в C# и их использовании.Provides links to information about special contextual characters in C# and their usage.

Директивы препроцессора C#C# Preprocessor Directives
Ссылки на сведения о командах компилятора для внедрения в исходном коде C#.Provides links to information about compiler commands for embedding in C# source code.

Параметры компилятора C# C# Compiler Options
Сведения о параметрах компилятора и их использовании.Includes information about compiler options and how to use them.

Ошибки компилятора C#C# Compiler Errors
Фрагменты кода, демонстрирующие причины и способы исправления ошибок и предупреждений компилятора C#.Includes code snippets that demonstrate the cause and correction of C# compiler errors and warnings.

Спецификация языка C#C# Language Specification
Спецификация языка C# версии 6.0The C# 6.0 language specification. Это черновой вариант для языка C# версии 6.0.This is a draft proposal for the C# 6.0 language. Этот документ будет пересмотрен в рамках работы с комитетом по стандартам C# ECMA.This document will be refined through work with the ECMA C# standards committee. Версия 5.0 была выпущена в декабре 2017 г. как стандартный 5-й выпуск ECMA-334.Version 5.0 has been released in December 2017 as the Standard ECMA-334 5th Edition document.

Возможности, которые были реализованы в языке C# версий более поздних чем 6.0, представлены в предложениях по спецификации языка.The features that have been implemented in C# versions after 6.0 are represented in language specification proposals. В этих документах описываются изменения спецификации языка, связанные с добавлением новых функций.These documents describe the deltas to the language spec in order to add these new features. Это черновой вариант для формы.These are in draft proposal form. Эти спецификации будут улучшены и отправлены в комитет по стандартам ECMA для официального анализа и внедрения в будущую версию стандарта C#.These specifications will be refined and submitted to the ECMA standards committee for formal review and incorporation into a future version of the C# Standard.

Предложения по спецификации C# 7.0C# 7.0 Specification Proposals
В версии C# 7.0 реализован ряд новых возможностей,There are a number of new features implemented in C# 7.0. включая сопоставления шаблонов, локальные функции, объявления выходной переменной, выражения throw, двоичные литералы и разделители между цифрами.They include pattern matching, local functions, out variable declarations, throw expressions, binary literals, and digit separators. Эта папка содержит спецификации для каждой из этих функций.This folder contains the specifications for each of those features.

Предложения по спецификации C# 7.1C# 7.1 Specification Proposals
В версию C# 7.1 добавлено несколько новых возможностей.There are new features added in C# 7.1. Можно написать метод Main, возвращающий Task или Task<int>.First, you can write a Main method that returns Task or Task<int>. Это позволяет добавлять модификатор async в метод Main.This enables you to add the async modifier to Main. Выражение default можно использовать без типа в тех расположениях, где возможен вывод типа.The default expression can be used without a type in locations where the type can be inferred. Кроме того, появилось еще одно дополнительное усовершенствование: вывод имен элементов кортежа.Also, tuple member names can be inferred. И, наконец, сопоставление шаблонов можно использовать с универсальными шаблонами.Finally, pattern matching can be used with generics.

Предложения по спецификации C# 7.2C# 7.2 Specification Proposals
В версию C#7.2 добавлен ряд простых функций.C# 7.2 added a number of small features. С помощью ключевого слова in можно передавать аргументы по ссылке только для чтения.You can pass arguments by readonly reference using the in keyword. Внесен ряд незначительных изменений для поддержки безопасности во время компиляции для Span и связанных типов.There are a number of low-level changes to support compile-time safety for Span and related types. В некоторых ситуациях можно использовать именованные аргументы, если следующие за ними аргументы являются позиционными.You can use named arguments where later arguments are positional, in some situations. Модификатор доступа private protected позволяет указывать, что вызывающие объекты ограничены производными типами, реализованными в той же сборке.The private protected access modifier enables you to specify that callers are limited to derived types implemented in the same assembly. Оператор

?: можно использовать для разрешения в ссылку на переменную.The ?: operator can resolve to a reference to a variable. С помощью разделителя начальных цифр можно форматировать шестнадцатеричные и двоичные числа.You can also format hexadecimal and binary numbers using a leading digit separator.

Предложения по спецификации C# 7.3C# 7.3 Specification Proposals
Версия C# 7.3 является очередным промежуточным выпуском, содержащим несколько небольших обновлений.C# 7.3 is another point release that includes several small updates. К параметрам универсальных типов можно применять новые ограничения.You can use new constraints on generic type parameters. Другие изменения упрощают работу с полями fixed, включая использование выделений stackalloc.Other changes make it easier to work with fixed fields, including using stackalloc allocations. Локальные переменные, объявленные с ключевым словом ref, можно переназначать для указания на новое хранилище.Local variables declared with the

ref keyword may be reassigned to refer to new storage. Можно применять атрибуты к автоматически реализуемым свойствам, предназначенным для созданного компилятором резервного поля.You can place attributes on auto-implemented properties that target the compiler-generated backing field. Переменные выражений можно использовать в инициализаторах.Expression variables can be used in initializers. Кортежи можно проверять на равенство (или неравенство).Tuples can be compared for equality (or inequality). Кроме того, были внесены некоторые улучшения в разрешение перегрузки.There have also been some improvements to overload resolution.

Предложения по спецификации C# 8.0C# 8.0 Specification Proposals
Версия C# 8.0 доступна для .NET Core 3.0.C# 8.0 is available with .NET Core 3.0. В число возможностей входят использование ссылочных типов, допускающих значения NULL, рекурсивное сопоставление шаблонов, методы интерфейса по умолчанию, асинхронные потоки, диапазоны и индексы, использование шаблонов и объявлений using, назначение объединения со значением NULL и члены экземпляров с доступом только на чтение.The features include nullable reference types, recursive pattern matching, default interface methods, async streams, ranges and indexes, pattern based using and using declarations, null coalescing assignment, and readonly instance members.

Использование среды разработки Visual Studio для C#Using the Visual Studio Development Environment for C#
Ссылки на концептуальные разделы и разделы задач, описывающие интегрированную среду разработки и редактор.Provides links to conceptual and task topics that describe the IDE and Editor.

Руководство по программированию на C#C# Programming Guide
Сведения об использовании языка программирования C#.Includes information about how to use the C# programming language.

Язык программирования С | Электроника для всех

В пособии приведено подробное описание наиболее распространенного языка программирования СИ для персональных компьютеров, совместимых с IBM PC, и описано применение средств языка на примерах задач работы со списками.

Учебное пособие предназначено для студентов всех специальностей,
аспирантов и инженерно-технических работников использующих вычислительную технику. Может быть использовано как справочное пособие для широкого круга программистов, как профессионалов, имеющих большой опыт работы на СИ, так и начинающих программировать на СИ.

Рецензенты: д.ф-м.н., проф. Афанасьев А.П.

ОГЛАВЛЕНИЕ

1.ОПИСАНИЕ ЯЗЫКА СИ

1.1. ЭЛЕМЕНТЫ ЯЗЫКА СИ
1.1.1. Используемые символы
1.1.2. Константы
1.1.3. Идентификатор
1.1.4. Ключевые слова
1.1.5. Использование комментариев в тексте программы

1.2. ТИПЫ ДАННЫХ И ИХ ОБ ЯВЛЕНИЕ
1.2.1 Категории типов данных
1.2.2. Целый тип данных
1.2.3. Данные плавающего типа
1.2.4. Указатели
1.2.5. Переменные перечислимого типа
1.2.6. Массивы
1.2.7. Структуры
1.2.8. Объединения (смеси-union)
1.2.9. Поля битов
1.2.10. Переменные с изменяемой структурой
1.2.11. Определение объектов и типов
1.2.12. Инициализация данных

1.3. ВЫРАЖЕНИЯ И ПРИСВАИВАНИЯ
1.3.1. Операнды и операции
1.3.2. Преобразования при вычислении выражений
1.3.3. Операции отрицания и дополнения
1.3.4. Операции разадресации и адреса
1.3.5. Операция sizeof
1.3.6. Мультипликативные операции
1.3.7. Аддитивные операции
1.3.8. Операции сдвига
1.3.9. Поразрядные операции

1.3.10. Логические операции
1.3.11. Операция последовательного вычисления
1.3.12. Условная операция
1.3.13. Операции увеличения и уменьшения
1.3.14. Простое присваивание
1.3.15. Составное присваивание
1.3.16. Приоритеты операций и порядок вычислений
1.3.17. Побочные эффекты
1.3.18. Преобразование типов

1.4. ОПЕРАТОРЫ
1.4.1. Оператор выражение
1.4.2. Пустой оператор
1.4.3. Составной оператор
;
1.4.4. Оператор if
1.4.5. Оператор switch
1.4.6. Оператор break
1.4.7. Оператор for
1.4.8. Оператор while
1.4.9. Оператор do while
1.4.10. Оператор continue
1.4.11. Оператор return
1.4.12. Оператор goto

1.5. ФУНКЦИИ
1.5.1. Определение и вызов функций
1.5.2. Вызов функции с переменным числом параметров
1.5.3. Передача параметров функции main

1.6. СТРУКТУРА ПРОГРАММЫ И КЛАССЫ ПАМЯТИ
1.6.1. Исходные файлы и объявление переменных
1.6.2. Объявления функций
1.6.3. Время жизни и область видимости программных объектов
1.6.4. Инициализация глобальных и локальных переменных

1.7. УКАЗАТЕЛИ И АДРЕСНАЯ АРИФМЕТИКА
1.7.1. Методы доступа к элементам массивов

1.7.2. Указатели на многомерные массивы
1.7.3. Операции с указателями
1.7.4. Массивы указателей
1.7.5. Динамическое размещение массивов

1.8. ДИРЕКТИВЫ ПРЕПРОЦЕССОРА
1.8.1. Директива #include
1.8.2. Директива #define
1.8.3. Директива #undef

2. ОРГАНИЗАЦИЯ СПИСКОВ И ИХ ОБРАБОТКА

2.1. ЛИНЕЙНЫЕ СПИСКИ
2.1.1. Методы организации и хранения линейных списков
2.1.2. Операции со списками при последовательном хранении
2.1.3. Операции со списками при связном хранении
2.1.4. Организация двусвязных списков
2.1.5. Стеки и очереди
2.1.6. Сжатое и индексное хранение линейных списков

2.2. СОРТИРОВКА И СЛИЯНИЕ СПИСКОВ
2.2.1. Пузырьковая сортировка
2.2.2. Сортировка вставкой
2.2.3. Сортировка посредством выбора
2.2.4. Слияние списков
2.2.5. Сортировка списков путем слияния
2.2.6. Быстрая и распределяющая сортировки

2.3. ПОИСК И ВЫБОР В ЛИНЕЙНЫХ СПИСКАХ
2.3.1. Последовательный поиск
2.3.2. Бинарный поиск
2.3.3. М-блочный поиск
2.3.4. Методы вычисления адреса
2.3.5. Выбор в линейных списках

2.4. РЕКУРСИЯ

Справочники

Справочники — это прикладные объекты конфигурации. Они позволяют хранить в информационной базе данные, имеющие одинаковую структуру и списочный характер. Это может быть, например, список сотрудников, перечень товаров, список поставщиков или покупателей.

Структура справочника

Каждый элемент справочника характеризуется кодом и наименованием. Система поддерживает режим автоматической нумерации элементов, при котором она самостоятельно может генерировать код для нового элемента справочника. Кроме этого система позволяет осуществлять контроль уникальности кодов справочника, не разрешая создавать элементы с одинаковыми кодами:

Справочники

Помимо кода и наименования, каждый элемент справочника, как правило, содержит некоторую дополнительную информацию, которая подробно описывает этот элемент. Например, для товара это может быть информация об артикуле, упаковке и т. п. Набор такой информации является одинаковым для всех элементов конкретного справочника, и для ее хранения служат реквизиты справочника:

Справочники

Кроме этого, каждый элемент справочника может содержать некоторый набор информации, которая одинакова по своей структуре, но различна по количеству, для разных элементов справочника. Например, для каждого сотрудника в справочнике Физические лица это может быть контактная информация или информация о составе семьи, образовании. Для хранения подобных данных служат табличные части справочника:

Справочники

Справочники могут поддерживать иерархическое расположение элементов. Например, в справочнике Номенклатура могут быть созданы группы: Бытовая техникаОбувьПродукты и т. д., в которых располагаются элементы, относящиеся к этим группам. Кроме того группы справочника могут включать в себя и другие группы, создавая тем самым многоуровневую иерархическую структуру.

Справочники

В справочниках возможен и другой вид иерархии, при котором элементы справочника будут относиться не к группам, а к другим элементам этого же справочника. Такой вид иерархии может использоваться, например, при создании справочника Задачи, где одна задача может включать в себя несколько других задач.

Справочники

Разные справочники могут находиться в состоянии подчинения, т. е. элементы одного справочника могут быть подчинены элементам или группам другого справочника. Например, справочник Кассы может быть подчинен справочнику Организации. Тогда при оформлении кассовых документов для некоторой организации можно будет выбрать кассу не среди всех имеющихся в программе касс, а среди касс, существующих только в этой организации:

Справочники

Справочники допускают также создание предопределенных элементов, которые существуют в справочнике всегда, вне зависимости от действий пользователя. Такие элементы справочника создаются разработчиком при разработке прикладного решения и не могут быть удалены или перемещены пользователем.

Например, если в основном прикладное решение будет внедряться на предприятиях одного государства, России, в справочник Страны мира сразу же можно добавить предопределенный элемент Россия, поскольку он понадобится подавляющему большинству пользователей.

Справочники

Формы справочника

Для того чтобы пользователь мог просматривать и изменять данные, содержащиеся в справочнике, система поддерживает несколько форм представления справочника. Система может автоматически генерировать все нужные формы справочника. Наряду с этим разработчик имеет возможность создать собственные формы, которые система будет использовать вместо форм по умолчанию:

Справочники

Форма списка

Для просмотра данных, содержащихся в справочнике, используется форма списка. Она позволяет выполнять навигацию по справочнику, добавлять, помечать на удаление и удалять элементы и группы справочника, перемещать элементы и группы. Форма списка может представлять данные в иерархическом и не иерархическом виде и позволяет выполнять сортировку и отбор отображаемой информации по нескольким критериям:

Справочники

Форма элемента

Для просмотра и изменения данных отдельных элементов справочника используется форма элемента. Как правило, она представляет данные в удобном для восприятия и редактирования виде:

Справочники

Форма группы

Система поддерживает отдельный вид формы для групп справочника. Это связано с тем, что, как правило, состав информации, относящейся к группе справочника, намного меньше, чем состав данных, имеющих отношение к отдельным элементам справочника:

Справочники

Форма выбора, форма выбора группы

При различных действиях пользователя в прикладном решении возникает необходимость выбора конкретных элементов справочников. Это может потребоваться, например, при создании приходной накладной, в которой должны быть перечислены определенные товары. В этом случае система использует форму выбора справочника, которая, обычно, содержит минимальный набор информации, необходимой для выбора того, или иного элемента:

Справочники

Кроме всех перечисленных форм, система поддерживает еще форму выбора группы справочника, предназначенную для выбора только среди групп, содержащихся в справочнике.

Макеты

Справочнику могут быть сопоставлены несколько макетов, содержащих данные, необходимые для обеспечения работы справочника:

Справочники

Макеты могут использоваться для формирования печатных форм справочника или для отображения дополнительной информации, имеющей отношение к справочнику.

Справочники в языке 1С 8.3, 8.2 (в примерах)

&НаСервере
Процедура СозданиеИИзменениеЭлементовИГруппСправочникаНаСервере()
 
    /// Как создать новый элемент справочника в 1с 8.3, 8.2
 
    // создадим новый элемент справочника Города
    // с именем Владивосток
    Владивосток = Справочники.Города.СоздатьЭлемент();
    Владивосток.Наименование = "Владивосток";
    Владивосток.Записать();
 
    /// Как создать новую группу справочника в 1с 8.3, 8.2
 
    // создадим новую группу справочника Города
    ГородаУМоря = Справочники.Города.СоздатьГруппу();
    ГородаУМоря.Наименование = "Города у моря";
    ГородаУМоря.Записать();
 
    /// Как перенести элемент справочника в другую группу в 1с 8.3, 8.2
 
    // перенесём созданный Владивосток в группу "Города у моря"
    Владивосток.Родитель = ГородаУМоря.Ссылка;
    Владивосток.Записать();
 
    /// Как внести изменения в элемент справочника по ссылке 
    /// в 1с 8.3, 8.2
 
    // найдём город Калькутта
    КалькуттаСсылка = Справочники.Города.НайтиПоНаименованию("Калькутта");
    Если Не КалькуттаСсылка.Пустая() Тогда
        // изменим и запишем численность жителей в городе
        Калькутта = КалькуттаСсылка.ПолучитьОбъект();
        Калькутта.Численность = 1000000;
        Калькутта.Записать();
    КонецЕсли;
 
    /// Как получить и проверить пустую ссылку типа справочник в 1с 8.3, 8.2
 
    ПустаяСсылка = Справочники.Города.ПустаяСсылка();
    Если ПустаяСсылка.Пустая() Тогда
        Сообщить("Ссылка действительно пустая.");
    КонецЕсли;
 
    /// Как узнать принадлежность элемента справочника группе
    /// с учетом уровней иерархии в 1с 8.3, 8.2
 
    ПермьСсылка = Справочники.Города.НайтиПоНаименованию("Пермь");
    РоссияСсылка = Справочники.Города.НайтиПоНаименованию("Россия");
 
    // проверим принадлежит ли город Пермь группе Россия
 
    Если ПермьСсылка.ПринадлежитЭлементу(РоссияСсылка) Тогда
        Сообщить("Элемент Пермь находится в группе Россия.");
    КонецЕсли;
 
    /// Как скопировать существующий элемент справочника в 1с 8.3, 8.2
 
    // скопируем элемент Пермь
 
    КопияПерми = ПермьСсылка.Скопировать();
    КопияПерми.Наименование = КопияПерми.Наименование + " КОПИЯ";
    КопияПерми.УстановитьНовыйКод();
    КопияПерми.Записать();
 
    /// Как выяснить уровень вложенности элемента справочника 
    /// в 1с 8.3, 8.2
 
    Сообщить(КопияПерми.Уровень()); // 1
 
    /// Как заблокировать элемент справочника перед изменениями 
    /// в 1с 8.3, 8.2
 
    // выполним блокировку элемента справочника
    // от изменения другими режимами или пользователями
 
    Пермь = ПермьСсылка.ПолучитьОбъект();
    Если Не Пермь.Заблокирован() Тогда
        Пермь.Заблокировать();
        // тут идёт какой-то долгий алгоритм
        // в результате которого мы меняем
        // заблокированный элемент
        Пермь.Численность = 5000;
        Пермь.Записать();
        // и только потом освобождаем его
        // для других режимов и пользователей
        Пермь.Разблокировать();
    КонецЕсли;
 
    /// Как заполнить новый элемент справочника на основании 
    /// в 1с 8.3, 8.2
 
    // в модуле справочника Города я определил процедуру
    // ОбработкаЗаполнения, которая обрабатывает ситуации
    // когда мы заполняем один элемент на основании
    // данных другого (см. в базе для скачивания)
 
    Хабаровск = Справочники.Города.СоздатьЭлемент();
    Хабаровск.Заполнить(
        Справочники.Города.НайтиПоНаименованию("Рио-де-Жанейро")
    );
    Хабаровск.Наименование = "Хабаровск";
    Хабаровск.Записать();
 
    /// Как пометить на удаление элемент справочника в 1с 8.3, 8.2
 
    // пометим на удаление только что созданный Хабаровск
    Хабаровск.УстановитьПометкуУдаления(
        Истина, // пометка удаления
        Ложь // включая подчиненные (если речь о группе справочника)
    );
    // метод Записать вызывать не нужно
 
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция ПолучитьКлиентаПоИмени(Имя)
    Возврат Справочники.Клиенты.НайтиПоНаименованию(Имя);
КонецФункции
 
/// Как открыть форму существующего элемента справочника 
/// по ссылке в 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакОткрытьФормуСуществующегоЭлементаСправочника(Команда)
 
    СсылкаНаЭлемент = ПолучитьКлиентаПоИмени("Андрей");
 
    ПараметрыФормы = Новый Структура("Ключ", СсылкаНаЭлемент);
 
    ОткрытьФорму(
        "Справочник.Клиенты.ФормаОбъекта", // имя формы
        ПараметрыФормы // параметры для формы
    );
 
КонецПроцедуры
 
/// Как открыть форму существующей группы справочника 
/// по ссылке в 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакОткрытьФормуСуществующейГруппыСправочника(Команда)
 
    СсылкаНаГруппу = ПолучитьКлиентаПоИмени("Vip");
 
    ПараметрыФормы = Новый Структура("Ключ", СсылкаНаГруппу);
 
    ОткрытьФорму(
        "Справочник.Клиенты.ФормаГруппы", // имя формы
        ПараметрыФормы // параметры для формы
    );
 
КонецПроцедуры
 
/// Как открыть форму выбора элемента справочника и
/// отследить её закрытие в 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакОткрытьФормуВыбораЭлементаСправочника(Команда)
 
    ОповещениеОЗакрытии = Новый ОписаниеОповещения("ПослеВыбораЭлемента",
        ЭтотОбъект);
 
    ОткрытьФорму(
        "Справочник.Клиенты.ФормаВыбора",,,,,,ОповещениеОЗакрытии        
    );
 
КонецПроцедуры
 
&НаКлиенте
Процедура ПослеВыбораЭлемента(Результат, Параметры) Экспорт
 
    Если Результат <> Неопределено Тогда
        Сообщить("Был выбран элемент " + Результат);
    КонецЕсли;	
 
КонецПроцедуры
 
/// Как открыть форму выбора группы справочника и
/// отследить её закрытие в 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакОткрытьФормуВыбораГруппыСправочника(Команда)
 
    ОповещениеОЗакрытии = Новый ОписаниеОповещения("ПослеВыбораГруппы",
        ЭтотОбъект);
 
    ОткрытьФорму(
        "Справочник.Клиенты.ФормаВыбораГруппы",,,,,,ОповещениеОЗакрытии        
    );
 
КонецПроцедуры
 
&НаКлиенте
Процедура ПослеВыбораГруппы(Результат, Параметры) Экспорт
 
    Если Результат <> Неопределено Тогда
        Сообщить("Была выбрана группа " + Результат);
    КонецЕсли;	
 
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция ПолучитьПеречислениеМужской()
    Возврат Перечисления.Пол.Мужской;
КонецФункции
 
/// Как открыть форму списка справочника и
/// установить отбор по реквизиту в 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакОткрытьФормаСпискаСправочникаСОтбором(Команда)
 
    // откроем список клиентов, оставив
    // только мужчин
 
    ПараметрыОтбора = Новый Структура;
    ПараметрыОтбора.Вставить("Пол", ПолучитьПеречислениеМужской());
 
    ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("Отбор", ПараметрыОтбора);
 
    ОткрытьФорму(
        "Справочник.Клиенты.ФормаСписка",
        ПараметрыФормы
    );
 
КонецПроцедуры
 
/// Как открыть форму списка справочника с нужным отображением
/// в 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакОткрытьФормуСпискаСправочникаСНужнымОтображением(Команда)
 
    // откроем список клиентов с отображением "Список"
 
    ФормаСписка = ПолучитьФорму("Справочник.Клиенты.ФормаСписка");    
    ФормаСписка.Открыть();
    ФормаСписка.Элементы.Список.Отображение = ОтображениеТаблицы.Список;
 
КонецПроцедуры
 
/// Как открыть форму только что созданного, но ещё
/// не записанного элемента справочника в 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакОткрытьФормуНовогоНеЗаписанногоСправочника(Команда)
 
    // получаем форму нового справочника
    ФормаНовогоСправочника = ПолучитьФорму(
        "Справочник.Еда.ФормаОбъекта",,, Истина); 
 
    // делаем копию её данных (так как напрямую их менять
    // нельзя)
    КопияДанныхФормы = ФормаНовогоСправочника.Объект;
 
    // заполняем эти данные на сервере
    ЗаполнитьДанныеФормыНаСервере(КопияДанныхФормы);
 
    // копируем заполненные данные в исходную форму
    КопироватьДанныеФормы(КопияДанныхФормы,
        ФормаНовогоСправочника.Объект);
 
    // показываем форму нового заполненного
    // элемента справочника пользователю
    ФормаНовогоСправочника.Открыть();
 
КонецПроцедуры
 
&НаСервере
Процедура ЗаполнитьДанныеФормыНаСервере(ДанныеФормы)
 
    // преобразуем данные формы в документ
    Еда = ДанныеФормыВЗначение(ДанныеФормы,
        Тип("СправочникОбъект.Еда")); 
 
    Еда.Наименование = "Груша";
    Еда.Калорийность = 500;
 
    // преобразуем документа обратно в данные формы
    ЗначениеВДанныеФормы(Еда, ДанныеФормы);
 
КонецПроцедуры
 
/// Скачать и выполнить эти примеры на компьютере

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *